I suggest you ...

improve the URL monitoring plugin

I find that the URL monitoring plugin gives a lot of false positives, which is stressing me out. I've disabled it for now. I'm not sure why it's doing this and happy to help you debug it.

16 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    anonymousanonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Jesse PasichnykJesse Pasichnyk commented  ·   ·  Flag as inappropriate

        Are you setting the hostname header, or just checking localhost with no header? I found that with my setup (nginx->fastcgi) that any health checks without a host header were timing out occassionally (from HAProxy), similar to the false positives i see from Scout url monitoring plugin.

        Setting a valid hostname header from HAProxy fixed its issues. Trying this now from Scout to see if its the same root cause.

        That said, the text description for "host override" originally confused me so I didn't use it. I now understand this as "Pass in this value as the host header to the requested url defined above".

      Feedback and Knowledge Base